Benutzer-Werkzeuge

Webseiten-Werkzeuge


php

Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
php [2019/05/30 22:40]
phi
php [2020/05/15 21:52] (aktuell)
phi
Zeile 5: Zeile 5:
 Momentan unterstützt Datenpark folgende PHP-Versionen:​ Momentan unterstützt Datenpark folgende PHP-Versionen:​
  
-^ Version ​^ Letztes Upgrade ​^ Support bis ^ Verwendung ^ phpinfo() ^ +^ Version ^ Support bis ^ Verwendung ^ phpinfo() ^ 
-| @lightgreen:​**7.3.6** | 2019-05-30  ​| [[http://​php.net/​supported-versions.php|2021-12-06]] | **Produktion ​(empfohlen)** ​| [[http://php73.datenpark.ch/​|phpinfo() PHP 7.3]] | +| @lightgreen:​**7.4.6** | [[http://​php.net/​supported-versions.php|2022-11-28]] | Produktion | [[https://php74.datenpark.ch/​|phpinfo() PHP 7.4]] | 
-| @lightgreen:​**7.2.19** | 2019-05-30  ​| [[http://​php.net/​supported-versions.php|2020-11-30]] | **Produktion** | [[https://php72.datenpark.ch/​|phpinfo() PHP 7.2]] | +| @lightgreen:​**7.3.18** | [[http://​php.net/​supported-versions.php|2021-12-06]] | **Produktion ​(empfohlen)** | [[https://php73.datenpark.ch/​|phpinfo() PHP 7.3]] | 
-| **7.1.30** | 2019-05-30 ​| [[http://​php.net/​supported-versions.php|2019-12-01]] | Produktion ​| [[https://php71.datenpark.ch/​|phpinfo() PHP 7.1]] |+| **7.2.31** | [[http://​php.net/​supported-versions.php|2020-11-30]] | legacy ​| [[https://php72.datenpark.ch/​|phpinfo() PHP 7.2]] |
  
 <note tip> <note tip>
-**PHP 7.ist die empfohlene Version für den produktiven Einsatz.**+**PHP 7.ist die empfohlene Version für den produktiven Einsatz.**
  
-Neue Webabos werden mit PHP 7.eingerichtet. Die PHP-Version Ihrer Website können Sie selbst via unser [[https://​my.datenpark.ch/​|Controlpanel]] umschalten.+Neue Webabos werden mit PHP 7.eingerichtet. Die PHP-Version Ihrer Website können Sie selbst via unser [[https://​my.datenpark.ch/​|Controlpanel]] umschalten
 +</​note>​ 
 + 
 +<note important>​ 
 +**PHP 7.1** wird **per Ende April 2020 komplett eingestellt**! Bitte migrieren Sie also schon heute auf die aktuellste PHP-Version. 
 + 
 +Unser Zeitplan der Umstellung:​ 
 + 
 +  * **Mo, 24. Feb 2020**: Vorankündigung im Wiki / per Newsletter / Blog / Tweet [[https://​twitter.com/​datenparkstatus|@datenparkstatus]] 
 +  * **Mo, 2. März 2020**: Ankündigung zur Einstellung PHP 7.1 per E-Mail, **5 Wochen Migrations-Frist** 
 +  * **Mo, 6. April 2020**: Automatische Umschaltung von PHP 7.1 auf 7.2, **3 Wochen Downgrade-Option** im [[https://​my.datenpark.ch|Controlpanel]] 
 +  * **Mo, 27. April 2020**: Entfernen von PHP 7.1 als Downgrade-Option im [[https://​my.datenpark.ch|Controlpanel]] 
 + 
 +Die Versionsvielfalt wird beibehalten - der Kunde hat die Wahl zwischen PHP 7.2, PHP 7.3 und PHP 7.4.
 </​note>​ </​note>​
  
Zeile 54: Zeile 67:
  
 Rufen Sie diese nun per Webbrowser auf. PHP zeigt sämtliche Konfigurations-Parameter. Rufen Sie diese nun per Webbrowser auf. PHP zeigt sämtliche Konfigurations-Parameter.
 +
 +===== OPcache Status =====
 +
 +Zend OPcache ist für alle Kunden standardmässig aktiviert. Um den PHP OPcache zu analysieren,​ haben Sie als Kunden Zugriff auf folgende zwei Tools:
 +
 +  * [[https://​github.com/​amnuts/​opcache-gui|opcache-gui]]
 +  * [[https://​github.com/​rlerdorf/​opcache-status|opcache-status]]
 +
 +Diese brauchen Sie nicht selbst zu installieren. Rufen Sie diese einfach innerhalb Ihrer eigenen Domain/​Subdomain auf, z.B.:
 +
 +  * ''<​KUNDENDOMAIN>/​opcache-gui''​ z.B. https://​www.nonprofit.ch/​opcache-gui
 +  * ''<​KUNDENDOMAIN>/​opcache-status''​ z.B. https://​www.nonprofit.ch/​opcache-status
 +
 +Diese Tools sind Passwort-geschützt. Sie können sich dazu Zugang verschaffen,​ indem Sie in unserem [[https://​my.onlime.ch/​|Controlpanel]] unter "​Verzeichnisschutz"​ eine **Passwort-Liste mit Name ''​status''​** (muss exakt so heissen! Gross/​Kleinschreibung beachten!) anlegen. Melden Sie sich dann für die OPcache status tools mit einem von Ihnen definierten Benutzer/​Passwort an.
  
 ===== Upgrade ===== ===== Upgrade =====
  
-Standardmässig wird Ihr Web-Abo mit PHP 7.2 eingerichtet. ​Sie können im [[https://​my.onlime.ch/​|Airpane Controlpanel]] via **PHP-Manager** jederzeit Ihre Version up/​downgraden. Pro Subdomain können Sie auch unterschiedliche PHP-Versionen im Einsatz haben.+Sie können im [[https://​my.datenpark.ch/​|Airpane Controlpanel]] via **PHP-Manager** jederzeit Ihre Version up/​downgraden. Pro Subdomain können Sie auch unterschiedliche PHP-Versionen im Einsatz haben.
  
 ===== PHP 7.3 ===== ===== PHP 7.3 =====
Zeile 71: Zeile 98:
 ===== PHP 7.2 ===== ===== PHP 7.2 =====
  
-  * [[https://​www.onlime.ch/​blog/​posts/​php-7-2-out-now|PHP 7.2 Out Now!]] 
   * [[http://​php.net/​releases/​7_2_0.php|PHP 7.2.0 Release Announcement]]   * [[http://​php.net/​releases/​7_2_0.php|PHP 7.2.0 Release Announcement]]
   * [[https://​github.com/​php/​php-src/​blob/​php-7.2.0/​UPGRADING|PHP 7.2 UPGRADE NOTES]]   * [[https://​github.com/​php/​php-src/​blob/​php-7.2.0/​UPGRADING|PHP 7.2 UPGRADE NOTES]]
php.1559248823.txt.gz · Zuletzt geändert: 2019/05/30 22:40 von phi