Benutzer-Werkzeuge

Webseiten-Werkzeuge


php

PHP

Aktuelle Versionen

Momentan unterstützt Datenpark folgende PHP-Versionen:

Version Support bis Verwendung phpinfo()
8.0.9 2023-11-26 Produktion (empfohlen) phpinfo() PHP 8.0
7.4.22 2022-11-28 Produktion phpinfo() PHP 7.4
7.3.29 2021-12-06 legacy phpinfo() PHP 7.3
PHP 8.0 ist die empfohlene Version für den produktiven Einsatz.

Neue Webabos werden mit PHP 8.0 eingerichtet. Die PHP-Version Ihrer Website können Sie selbst via unser Controlpanel umschalten.

Um die Konfiguration innerhalb Ihres Webabos anzusehen, erstellen Sie einfach eine Datei namens phpinfo.php mit folgendem Inhalt:

<?php
phpinfo();

Rufen Sie diese nun per Webbrowser auf. PHP zeigt sämtliche Konfigurations-Parameter.

OPcache Status

Zend OPcache ist für alle Kunden standardmässig aktiviert. Um den PHP OPcache zu analysieren, haben Sie als Kunden Zugriff auf folgende zwei Tools:

Diese brauchen Sie nicht selbst zu installieren. Rufen Sie diese einfach innerhalb Ihrer eigenen Domain/Subdomain auf, z.B.:

Diese Tools sind Passwort-geschützt. Sie können sich dazu Zugang verschaffen, indem Sie in unserem Controlpanel unter „Verzeichnisschutz“ eine Passwort-Liste mit Name status (muss exakt so heissen! Gross/Kleinschreibung beachten!) anlegen. Melden Sie sich dann für die OPcache status tools mit einem von Ihnen definierten Benutzer/Passwort an.

Upgrade

Sie können im Airpane Controlpanel via PHP-Manager jederzeit Ihre Version up/downgraden. Pro Subdomain können Sie auch unterschiedliche PHP-Versionen im Einsatz haben.

php.txt · Zuletzt geändert: 2021/08/02 10:51 von phi